libcmlutil-smlnj_110.79-4_amd64.deb


Advertisement

Description

libcmlutil-smlnj - Concurrent ML utility library

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename libcmlutil-smlnj_110.79-4_amd64.deb
Package name libcmlutil-smlnj
Package version 110.79
Package release 4
Package architecture amd64
Package type deb
Category devel
Homepage http://www.smlnj.org/
License -
Maintainer Debian QA Group <packages@qa.debian.org>
Download size 33.17 KB
Installed size 96.00 KB
Not all modules in the normal SML/NJ library are thread safe. This
library provides thread-safe implementations of these
libraries.

Alternatives

Package Version Architecture Repository
libcmlutil-smlnj_110.79-4_i386.deb 110.79 i386 Debian Main
libcmlutil-smlnj - - -

Requires

Name Value
libcml-smlnj = 110.79-4

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libcmlutil-smlnj_110.79-4_amd64.deb
Source Package smlnj

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libcmlutil-smlnj deb package:
    # sudo apt-get install libcmlutil-smlnj

Files

Path
/usr/lib/smlnj/lib/cml-lib/.cm/x86-unix/smlnj-lib.cm
/usr/lib/smlnj/lib/cml-lib/.cm/x86-unix/trace-cml.cm
/usr/share/doc/libcmlutil-smlnj/changelog.Debian.gz
/usr/share/doc/libcmlutil-smlnj/copyright

Changelog

2017-08-08 - gregor herrmann <gregoa@debian.org>
smlnj (110.79-4) unstable; urgency=medium
* QA upload.
* Fix "FTBFS: Unescaped left brace in regex is illegal here in regex":
extend debian/patches/mltex2html-perl-fixes to escape literal opening
braces in mltex2html script.
(Closes: #871335)
2017-07-03 - Adrian Bunk <bunk@debian.org>
smlnj (110.79-3) unstable; urgency=medium
* QA upload.
* Update the build dependency from texlive-math-extra
to texlive-science.
* Fix a spelling error in the ml-burg package description.
2016-09-13 - James McCoy <jamessan@debian.org>
smlnj (110.79-2) unstable; urgency=medium
* Add mltex2html-perl-fixes patch.  Fixes FTBFS when '.' is not part of @INC
(Closes: #837263) and unescaped '{' in regex.
* Orphan package and set Maintainer to QA Group.
2016-08-04 - James McCoy <jamessan@debian.org>
smlnj (110.79-1) unstable; urgency=medium
* New upstream release.
+ Remove all patches, merged upstream.
* Add latexmk Build-Depends-Indep for new documentation build process.
* Use secure URLs for Vcs-*
* Remove obsolete Breaks from transition to triggers
* Declare compliance with policy 3.9.8, no changes required
2015-07-22 - James McCoy <jamessan@debian.org>
smlnj (110.78-2) unstable; urgency=medium
* Ensure build-dir is created before build-indep tries to use it.
* Fix FTBFS on powerpc.
2015-07-22 - James McCoy <jamessan@debian.org>
smlnj (110.78-1) unstable; urgency=medium
* New upstream release
* debian/mkorig: Handle the new doc tarball.
* Switch to 3.0 (quilt) source format
* Fix i386 build on Linux 4.x kernels.  (Closes: #790283)
* Replace Debian man pages with new upstream man pages.
* Perform build in a build directory for easy cleanup.
2014-06-28 - James McCoy <jamessan@debian.org>
smlnj (110.76-2) unstable; urgency=medium
* debian/control: Add Vcs-* fields
* debian/rules: Actually build Arch: all packages when build/binary targets
are used.
* Include documentation for ml-burg, ml-lex, and ml-yacc
+ control: Add texlive-generic-recommended and transfig to
Build-Depends-Indep
+ rules: Convert tree.fig to tree.ps to build ml-burg documentation
+ smlnj-doc: Install ml-burg, ml-lex, and ml-yacc manuals
+ Add doc-base registration for ml-burg, ml-lex, and ml-yacc
* Update man pages to refer to installed documentation  (Closes: #752914)
* Bump Standards-Version to 3.9.5, no changes required
2013-09-16 - James McCoy <jamessan@debian.org>
smlnj (110.76-1) unstable; urgency=low
* New upstream version.
+ Fix comparisons of Int64 on amd64.  (Closes: #709459)
2013-05-08 - James McCoy <jamessan@debian.org>
smlnj (110.75-1) unstable; urgency=low
* New upstream version.
* Use interest-noawait for smlnj-runtime.
2012-10-05 - James McCoy <jamessan@debian.org>
smlnj (110.74-2) unstable; urgency=low
* Stop shipping /usr/lib/smlnj/bin/mkorig.  This is just used for packaging
purposes.
* Install config/extrapathconfig as seed for pathconfig trigger.  (Closes:
#689123)
* Add /usr/lib/smlnj trigger to smlnj-runtime to allow updating pathconfig
automatically.
* Remove {pkg-,}{de,}register scripts.  Updating pathconfig is now handled
by triggers.
* Remove no longer needed postinst/prerm maintainer scripts.
* Add Breaks for packages installing files under /usr/lib/smlnj

See Also

Package Description
libcmocka-dev_1.1.3-1_amd64.deb development files for the CMocka unit testing framework
libcmocka0_1.1.3-1_amd64.deb library for the CMocka unit testing framework
libcmor-dev_3.4.0-2_amd64.deb Development files for Climate Model Output Rewriter
libcmor2_3.4.0-2_amd64.deb Climate Model Output Rewriter library
libcmph-dev_2.0.2-1_amd64.deb C Minimal Perfect Hashing Library development files
libcmph-tools_2.0.2-1_amd64.deb C Minimal Perfect Hashing Library command line utilities
libcmph0_2.0.2-1_amd64.deb C Minimal Perfect Hashing Library
libcmrt-dev_1.0.6+dfsg1-1+b1_amd64.deb C bindings for media runtime -- development headers
libcmrt1_1.0.6+dfsg1-1+b1_amd64.deb C bindings for Intel Media Runtime
libcmtspeechdata-dev_2.1.1+git20160721~8efc468-2_amd64.deb modem speech data handling library (devel files)
libcmtspeechdata-doc_2.1.1+git20160721~8efc468-2_all.deb modem speech data handling library (documentation)
libcmtspeechdata-utils_2.1.1+git20160721~8efc468-2_amd64.deb modem speech data handling library (utils)
libcmtspeechdata0_2.1.1+git20160721~8efc468-2_amd64.deb modem speech data handling library
libcneartree-dev_5.1.1+dfsg1-1_amd64.deb Library and headers for solving the Nearest Neighbor Problem
libcneartree7_5.1.1+dfsg1-1_amd64.deb Library for solving the Nearest Neighbor Problem
Advertisement
Advertisement