libclutter-perl_1.110-6_all.deb


Advertisement

Description

libclutter-perl - perl bindings for an Open GL based interactive canvas library

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename libclutter-perl_1.110-6_all.deb
Package name libclutter-perl
Package version 1.110
Package release 6
Package architecture all
Package type deb
Category devel::lang:perl devel::library implemented-in::perl perl uitoolkit::gtk
Homepage https://metacpan.org/release/Clutter
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 8.22 KB
Installed size 30.00 KB
Clutter is an Open GL based interactive canvas library, designed for creating
fast, mainly 2D single window applications such as media box UIs,
presentations, kiosk style applications and so on.
This package contains the Perl bindings.

Alternatives

Package Version Architecture Repository
libclutter-perl_1.110-6_all.deb 1.110 all Debian Main
libclutter-perl - - -

Requires

Name Value
gir1.2-clutter-1.0 -
libcairo-gobject-perl -
libglib-object-introspection-perl -
libglib-perl -
libpango-perl -
perl -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libclutter-perl_1.110-6_all.deb
Source Package libclutter-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libclutter-perl deb package:
    # sudo apt-get install libclutter-perl

Files

Path
/usr/share/doc/libclutter-perl/TODO.Debian
/usr/share/doc/libclutter-perl/changelog.Debian.gz
/usr/share/doc/libclutter-perl/copyright
/usr/share/doc/libclutter-perl/examples/basic-actor.pl
/usr/share/lintian/overrides/libclutter-perl
/usr/share/man/man3/Clutter.3pm.gz
/usr/share/perl5/Clutter.pm

Changelog

2018-10-29 - intrigeri <intrigeri@debian.org>
libclutter-perl (1.110-6) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* Update Vcs-* headers for switch to salsa.debian.org
[ intrigeri ]
* Declare compliance with Debian Policy 4.2.1.
* Bump debhelper compatibility level to 11.
* Remove obsolete upstream VCS URLs.
2017-06-24 - intrigeri <intrigeri@debian.org>
libclutter-perl (1.110-5) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
[ gregor herrmann ]
* debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
* Remove Ryan Niebur from Uploaders. Thanks for your work!
[ intrigeri ]
* Remove duplicate word in debian/changelog.
* Bump debhelper compat level to 10 and adjust build-dependencies accordingly.
* Declare compliance with Standards-Version 4.0.0: no change required.
2015-12-31 - gregor herrmann <gregoa@debian.org>
libclutter-perl (1.110-4) unstable; urgency=medium
* Rename autopkgtest configuration file(s) as per new pkg-perl-
autopkgtest schema.
* Convert package to arch:all. It contains only arch-independent
code. (Closes: #809399)
* Update years of packaging copyright.
2015-05-23 - intrigeri <intrigeri@debian.org>
libclutter-perl (1.110-3) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ intrigeri ]
* Add debian/upstream/metadata
* Add upstream Git repository information to debian/upstream/metadata.
* Declare compliance with Standards-Version 3.9.6.
* Mark package as autopkgtest-able, but disable upstream test
that relies on DRI2 etc., which we have not in adt-run environment.
* Stop installing the empty upstream NEWS file.
* Update upstream and packaging copyright information.
* Override the Lintian no-upstream-changelog check: upstream ships no
such thing anymore.
2014-03-09 - intrigeri <intrigeri@debian.org>
libclutter-perl (1.110-2) unstable; urgency=low
[ gregor herrmann ]
* debian/control: update {versioned,alternative} (build) dependencies.
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ intrigeri ]
* Bump debhelper compat level to 9.
* Declare compatibility with Standards-Version 3.9.5.
* Reformat debian/control with cme fix dpkg.
2012-06-03 - intrigeri <intrigeri@debian.org>
libclutter-perl (1.110-1) unstable; urgency=low
[ gregor herrmann ]
* Use source format 3.0 (quilt).
* Run tests under xvfb.
* Remove debian/source/local-options; abort-on-upstream-changes
and unapply-patches are default in dpkg-source since 1.16.1.
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ intrigeri ]
* Imported Upstream version 1.110 (Closes: #620936)
* Drop pod-fixes.patch: patched .xs files are not shipped by the new
introspection-based library anymore.
* Refresh dependencies.
* Update debian/copyright to today's standards, thanks to cme.
* Disable dh_auto_test: the only test case segfaults in pbuilder + xvfb-run.
Note that it passes flawlessly inside a regular X session.
* Add myself to uploaders.
* Bump standards version to 3.9.3 (no change required).

See Also

Package Description
libclxclient-dev_3.9.0-5_amd64.deb X Window System C++ access library (development files)
libclxclient3_3.9.0-5_amd64.deb X Window System C++ access library (shared library)
libcmap-dev_3.0.1-2_amd64.deb cluster engine CMAP library development
libcmap4_3.0.1-2_amd64.deb cluster engine CMAP library
libcmark-dev_0.28.3-1_amd64.deb development files for CommonMark parsing and rendering library
libcmark-gfm-dev_0.28.3.gfm.19-3_amd64.deb CommonMark GitHub flavor gfm library dev files
libcmark-gfm-extensions-dev_0.28.3.gfm.19-3_amd64.deb CommonMark GitHub flavor gfm extensions library dev files
libcmark-gfm-extensions0_0.28.3.gfm.19-3_amd64.deb CommonMark GitHub flavor gfm extension library
libcmark-gfm0_0.28.3.gfm.19-3_amd64.deb CommonMark GitHub flavor gfm library
libcmark0_0.28.3-1_amd64.deb CommonMark parsing and rendering library
libcmdliner-ocaml-dev_1.0.2-1_amd64.deb declarative definition of command line interfaces
libcminpack-dev_1.3.6-4_amd64.deb Nonlinear equations and nonlinear least squares problems - development
libcminpack1_1.3.6-4_amd64.deb Nonlinear equations and nonlinear least squares problems - runtime
libcmis-0.5-5v5_0.5.2-1_amd64.deb CMIS protocol client library
libcmis-dev_0.5.2-1_amd64.deb CMIS protocol client library -- development
Advertisement
Advertisement