libclaw-application1v5_1.7.4-2_amd64.deb


Advertisement

Description

libclaw-application1v5 - Set of classes to ease the initialisation of the program

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename libclaw-application1v5_1.7.4-2_amd64.deb
Package name libclaw-application1v5
Package version 1.7.4
Package release 2
Package architecture amd64
Package type deb
Category libs role::shared-lib
Homepage http://libclaw.sourceforge.net
License -
Maintainer Debian Games Team <pkg-games-devel@lists.alioth.debian.org>
Download size 33.35 KB
Installed size 105.00 KB
Part of the libclaw library.
This library is intended to help to manage the arguments of your program, with
automatic management of short/long arguments and help message.

Alternatives

Package Version Architecture Repository
libclaw-application1v5_1.7.4-2_i386.deb 1.7.4 i386 Debian Main
libclaw-application1v5 - - -

Requires

Name Value
libc6 >= 2.14
libclaw-logger1v5 = 1.7.4-2
libgcc1 >= 1:3.0
libstdc++6 >= 5.2

Conflicts

Name Value
libclaw-application1 -

Replaces

Name Value
libclaw-application1 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libclaw-application1v5_1.7.4-2_amd64.deb
Source Package libclaw

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libclaw-application1v5 deb package:
    # sudo apt-get install libclaw-application1v5

Files

Path
/usr/lib/libclaw_application.so.1
/usr/lib/libclaw_application.so.1.7.4
/usr/share/doc/libclaw-application1v5/changelog.Debian.gz
/usr/share/doc/libclaw-application1v5/changelog.gz
/usr/share/doc/libclaw-application1v5/copyright

Changelog

2017-08-17 - Markus Koschany <apo@debian.org>
libclaw (1.7.4-2) unstable; urgency=medium
* Team upload.
* Add gcc7.patch and fix FTBFS with GCC 7.
* Switch to compat level 10.
* Declare compliance with Debian Policy 4.0.1.
2016-08-21 - Markus Koschany <apo@debian.org>
libclaw (1.7.4-1) unstable; urgency=medium
* Team upload.
* Imported Upstream version 1.7.4.
* Declare compliance with Debian Policy 3.9.8.
* wrap-and-sort -sa.
* Vcs-Browser: Use the canonical URI and https.
* d/control: Remove redundant Homepage fields.
* Add get-orig-source target.
* Add boost1.61.patch and work around a FTBFS with Boost 1.61.
* Add gcc6-ftbfs.patch and fix FTBFS error: cannot convert
'std::basic_istream<char>' to 'bool' in initialization. (Closes: #811611)
Thanks to Martin Michlmayr for the report.
* Fix debian/copyright and point to the LGPL-2.1 license.
2016-01-21 - Tobias Frost <tobi@debian.org>
libclaw (1.7.3-2) unstable; urgency=medium
* Team upload.
* Depend on libpng-dev only -- libpng1.6 transition
2015-08-16 - Julien Cristau <jcristau@debian.org>
libclaw (1.7.3-1.1) unstable; urgency=medium
* Non-maintainer upload.
* Rename library packages for g++5 ABI transition (closes: 791106).
2013-06-28 - Barry deFreese <bdefreese@debian.org>
libclaw (1.7.3-1) unstable; urgency=low
* New upstream release.
+ Drop unneeded patches.
* Build-dep libpng-dev not libpng12-dev. (Closes: #662394).
* Move to source format 3.0 (quilt).
+ Drop quilt build-dep.
+ Remove file debian/README.source.
* Bump debhelper build-dep and compat to 9.
* Add Homepage tag to source package.
* Update VCS tags.
* Fix watch file.
* Bump Standards Version to 3.9.4.
2012-05-27 - Dmitrijs Ledkovs <xnox@debian.org>
libclaw (1.7.0-3) unstable; urgency=low
* Team upload
* Fix build failure with GCC 4.7, thanks to Matthias Klose (Closes: #671475)
2011-09-14 - Gonéri Le Bouder <goneri@rulezlan.org>
libclaw (1.7.0-2) unstable; urgency=low
* Upload in unstable
* Add myself in Uploader
2011-08-27 - Julien Jorge <julien.jorge@gamned.org>
libclaw (1.7.0-1) experimental; urgency=low
* New upstream release.
* Add a B-D on libboost-dev
* Remove debian/claw-config.man.sgml and use the manpage provided with in the
upstream package.
2011-08-21 - Julien Jorge <julien.jorge@gamned.org>
libclaw (1.6.1-6) unstable; urgency=low
[ Julien Jorge ]
* Add missing include directive for libpng1.5 transition. Thanks to
Nobuhiro Iwmatsu <iwamatsu@nigauri.org>. (Closes: #635951)
* Install the CMake module in prefix/share/cmake/libclaw. (Closes: #635980)
2011-07-20 - Bruno "Fuddl" Kleinert <fuddl@debian.org>
libclaw (1.6.1-5) unstable; urgency=low
* Team upload.
* Prepare for libjpeg8 transition. Build-depend on libjpeg-dev instead of
libjpeg62-dev. Make libclaw-graphic-dev depend on libjpeg-dev instead of
libjpeg62-dev. (Closes: #629960)
* Comment out removal of
$(CURDIR)/debian/tmp/usr/share/doc/libclaw1/html/jquery.js in
debian/rules as it's apperently not installed there at all and lead to a
FTBFS.

See Also

Package Description
libclaw-configuration-file-dev_1.7.4-2_amd64.deb Class to process configuration files (development files)
libclaw-configuration-file1v5_1.7.4-2_amd64.deb Class to process configuration files
libclaw-dev_1.7.4-2_amd64.deb Claw is a generalist C++ library (development files)
libclaw-doc_1.7.4-2_all.deb Claw is a generalist C++ library (documentation files)
libclaw-dynamic-library-dev_1.7.4-2_amd64.deb Class to ease the manipulation of dynamic libraries (development files)
libclaw-dynamic-library1v5_1.7.4-2_amd64.deb Class to ease the manipulation of dynamic libraries
libclaw-graphic-dev_1.7.4-2_amd64.deb Set of classes for image manipulation (development files)
libclaw-graphic1v5_1.7.4-2_amd64.deb Set of classes for image manipulation
libclaw-i18n_1.7.4-2_all.deb Internationalisation files for libclaw
libclaw-logger-dev_1.7.4-2_amd64.deb Flexible log system (development files)
libclaw-logger1v5_1.7.4-2_amd64.deb Flexible log system
libclaw-net-dev_1.7.4-2_amd64.deb C++ standard stream interface for Unix sockets (development files)
libclaw-net1v5_1.7.4-2_amd64.deb C++ standard stream interface for Unix sockets
libclaw-tween-dev_1.7.4-2_amd64.deb C++ tweeners (development files)
libclaw-tween1v5_1.7.4-2_amd64.deb C++ tweeners
Advertisement
Advertisement