libcaffe-cpu1_1.0.0+git20180821.99bd997-2+b1_amd64.deb


Advertisement

Description

libcaffe-cpu1 - library of Caffe, deep learning framework (CPU_ONLY)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename libcaffe-cpu1_1.0.0+git20180821.99bd997-2+b1_amd64.deb
Package name libcaffe-cpu1
Package version 1.0.0+git20180821.99bd997
Package release 2+b1
Package architecture amd64
Package type deb
Category libs role::shared-lib
Homepage http://caffe.berkeleyvision.org
License -
Maintainer Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>
Download size 781.85 KB
Installed size 3.76 MB
Caffe is a deep learning framework made with expression, speed,
and modularity in mind. It is developed by the Berkeley AI Research
Lab (BAIR) and community contributors.
It contains caffe shared library, configured as CPU_ONLY.

Alternatives

Package Version Architecture Repository
libcaffe-cpu1_1.0.0+git20180821.99bd997-2+b1_i386.deb 1.0.0+git20180821.99bd997 i386 Debian Main
libcaffe-cpu1 - - -

Requires

Name Value
libatlas3-base -
libblas.so.3 -
libblas3 -
libboost-filesystem1.67.0 -
libboost-python1.67.0 -
libboost-system1.67.0 -
libboost-thread1.67.0 -
libc6 >= 2.27
libgcc1 >= 1:3.0
libgflags2.2 -
libgoogle-glog0v5 -
libhdf5-103 -
libleveldb1d -
liblmdb0 >= 0.9.7
libmkl-rt -
libopenblas-base -
libopencv-core3.2 -
libopencv-imgcodecs3.2 -
libopencv-imgproc3.2 -
libprotobuf17 -
libpython3.7 >= 3.7.0
libstdc++6 >= 5.2

Conflicts

Name Value
libcaffe-cuda1 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libcaffe-cpu1_1.0.0+git20180821.99bd997-2+b1_amd64.deb
Source Package caffe

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libcaffe-cpu1 deb package:
    # sudo apt-get install libcaffe-cpu1

Files

Path
/usr/lib/x86_64-linux-gnu/libcaffe.so.1.0.0
/usr/share/doc/libcaffe-cpu1/changelog.Debian.amd64.gz
/usr/share/doc/libcaffe-cpu1/changelog.Debian.gz
/usr/share/doc/libcaffe-cpu1/copyright
/usr/share/lintian/overrides/libcaffe-cpu1

Changelog

2018-12-06 - Mo Zhou <cdluminate@gmail.com>
caffe (1.0.0+git20180821.99bd997-2) unstable; urgency=medium
* Ignore precision issue on mips* machines which may lack an FPU.
(Closes: #915108)
2018-11-25 - Mo Zhou <cdluminate@gmail.com>
caffe (1.0.0+git20180821.99bd997-1) unstable; urgency=medium
[ Mo Zhou ]
* New upstream version 1.0.0+git20180821.99bd997
* libcaffe.so Depends on OpenBLAS or Atlas or MKL. (Closes: #898941)
* Package caffe-cpu doesn't need to Depend on libopenblas-base or alike.
* Bump Standards-Version to 4.2.0 (no change).
[ Dimitri John Ledkov ]
* Fix finding the right boost-python. (1.0.0-8ubuntu1) (Closes: #914067)
2018-05-20 - Mo Zhou <cdluminate@gmail.com>
caffe (1.0.0-8) unstable; urgency=medium
* Fix FTBFS on Arch=all due to installing a file that is not built.
(Closes: #899133)
* Add upstream unittest to autopkgtest control file.
2018-05-19 - Mo Zhou <cdluminate@gmail.com>
caffe (1.0.0-7) unstable; urgency=medium
* Install upstream unittests as a part of the tools package.
* Build-Depend on python3-distutils (See: #894203)
* Strip unneeded --parallel option from rules, because compat=11 .
* Bump X-Python-Version to 3.5 .
* Bump Standards-Version to 4.1.4 (no change).
* Update watch file to version=4 .
2018-01-27 - Mo Zhou <cdluminate@gmail.com>
caffe (1.0.0-6) unstable; urgency=medium
* Bump debhelper compat to 11.
* Bump Standards-Version to 4.1.3 (no change).
* Vcs-* fields point to Salsa.
* Don't hardcode python3.5 in the patch.
* Fix insecure-copyright-format-uri.
2017-12-19 - Mo Zhou <cdluminate@gmail.com>
caffe (1.0.0-5) unstable; urgency=medium
* Apply updates from upstream master branch.
- Remove merged patch cmake-change-static-lib-name.patch.
* Bump Standards-Version to 4.1.2 (no change).
* Update description of caffe-doc.
2017-12-18 - Mo Zhou <cdluminate@gmail.com>
caffe (1.0.0-4) unstable; urgency=medium
* Update my name in control and copyright.
* Bump Standards-Version to 4.1.1 . No change needed.
* Use dh_missing --list-missing instead of dh_install --list-missing .
* Remove the dirty hacks in the doc build.
* Add several libjs* dependencies for the doc package.
* Don't build binaries in indep-only build mode.
2017-06-23 - Zhou Mo <cdluminate@gmail.com>
caffe (1.0.0-3) unstable; urgency=medium
* Upload to unstable.
* Set Multi-Arch of the dev package to same.
* Bump Standards Version to 4.0.0 (No change needed).
2017-05-15 - Zhou Mo <cdluminate@gmail.com>
caffe (1.0.0-2) experimental; urgency=medium
* Rename static library libproto.a -> libcaffeproto.a and add it back
to the -dev package. (Closes: #862528)
2017-04-17 - Zhou Mo <cdluminate@gmail.com>
caffe (1.0.0-1) experimental; urgency=medium
* New upstream release. The first upstream stable release.
The version number is imported as 1.0.0 instead of 1.0 (upstream)
for correct dpkg version comparison.
* Patchset update:
- Remove merged patch make-using-gnuinstalldirs .
- Remove merged patch fix-more-float-comparison-precision-issue .
- Drop patch post_rc5_upstream_updates.patch .
* Rules: update CAFFE_SOVER and get-orig-source accordingly.
* Control:
+ Add missing dependency: python3-pydotplus .
+ Update package description: upstream lab renamed from BVLC to BAIR.

See Also

Package Description
libcaffeine-java_2.6.2-1_all.deb High performance caching library
libcairo-5c0_1.17_amd64.deb library for cairo nickle bindings
libcairo-gobject-perl_1.004-3+b1_amd64.deb integrate Cairo into the Glib type system in Perl
libcairo-gobject2_1.16.0-4_amd64.deb Cairo 2D vector graphics library (GObject library)
libcairo-ocaml-dev_1.2.0-6+b2_amd64.deb OCaml bindings for Cairo
libcairo-ocaml_1.2.0-6+b2_amd64.deb OCaml bindings for Cairo (runtime)
libcairo-perl_1.106-3+b1_amd64.deb Perl interface to the Cairo graphics library
libcairo-script-interpreter2_1.16.0-4_amd64.deb Cairo 2D vector graphics library (script interpreter)
libcairo1.10-cil_2.99.3-3_amd64.deb CLI binding for Cairo
libcairo2-dev_1.16.0-4_amd64.deb Development files for the Cairo 2D graphics library
libcairo2-doc_1.16.0-4_all.deb Documentation for the Cairo Multi-platform 2D graphics library
libcairo2_1.16.0-4_amd64.deb Cairo 2D vector graphics library
libcairomm-1.0-1v5_1.12.2-4_amd64.deb C++ wrappers for Cairo (shared libraries)
libcairomm-1.0-dev_1.12.2-4_amd64.deb C++ wrappers for Cairo (development files)
libcairomm-1.0-doc_1.12.2-4_all.deb C++ wrappers for Cairo (documentation)
Advertisement
Advertisement