gr-osmosdr_0.1.4-14+b10_amd64.deb


Advertisement

Description

gr-osmosdr - Gnuradio blocks from the OsmoSDR project

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename gr-osmosdr_0.1.4-14+b10_amd64.deb
Package name gr-osmosdr
Package version 0.1.4
Package release 14+b10
Package architecture amd64
Package type deb
Category devel::library libdevel role::devel-lib
Homepage http://sdr.osmocom.org/trac/wiki/GrOsmoSDR
License -
Maintainer A. Maitland Bottoms <bottoms@debian.org>
Download size 212.85 KB
Installed size 1.40 MB
The Osmocom project is a family of projects regarding Open source
mobile communications.
While primarily being developed for the OsmoSDR hardware, this block
as well supports:
- FUNcube Dongle through libgnuradio-fcd
- FUNcube Dongle Pro+ through gr-fcdproplus
- sysmocom OsmoSDR Devices through libosmosdr
- RTL2832U based DVB-T dongles through librtlsdr
- RTL-TCP spectrum server (see librtlsdr project)
- MSi2500 based DVB-T dongles through libmirisdr
- gnuradio .cfile input through libgnuradio-blocks
- RFSPACE SDR-IQ, SDR-IP, NetSDR (incl. X2 option)
- Great Scott Gadgets HackRF through libhackrf
- Nuand LLC bladeRF through libbladeRF library
- Ettus USRP Devices through Ettus UHD library
- Fairwaves UmTRX through Fairwaves' fork of UHD
- AIRSPY Receiver
- AIRSPY HF+ Receiver
- SoapySDR support
- Red Pitaya SDR transceiver (http://bazaar.redpitaya.com)
- FreeSRP through libfreesrp
By using the OsmoSDR block you can take advantage of a common
software API in your application(s) independent of the underlying
radio hardware.

Alternatives

Package Version Architecture Repository
gr-osmosdr_0.1.4-14+b10_i386.deb 0.1.4 i386 Debian Main
gr-osmosdr - - -

Requires

Name Value
libairspy0 >= 1.0.9~
libairspyhf1 -
libbladerf1 -
libboost-atomic1.67.0 -
libboost-chrono1.67.0 -
libboost-date-time1.67.0 -
libboost-system1.67.0 -
libboost-thread1.67.0 -
libc6 >= 2.14
libfreesrp0 -
libgcc1 >= 1:3.0
libgnuradio-blocks3.7.13 -
libgnuradio-fcd3.7.13 -
libgnuradio-fcdproplus3.7.11 -
libgnuradio-iqbalance3.7.11 -
libgnuradio-osmosdr0.1.4 >= 0.1.4-13
libgnuradio-pmt3.7.13 -
libgnuradio-runtime3.7.13 -
libgnuradio-uhd3.7.13 -
libhackrf0 -
liblog4cpp5v5 -
libmirisdr0 -
libosmosdr0 -
libpython2.7 >= 2.7
librtlsdr0 -
libsoapysdr0.6 -
libstdc++6 >= 5.2
libuhd3.13.1 -
libvolk1.4 -
python << 2.8
python >= 2.7~
python:any << 2.8
python:any >= 2.7~

Download

Type URL
Mirror ftp.br.debian.org
Binary Package gr-osmosdr_0.1.4-14+b10_amd64.deb
Source Package gr-osmosdr

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install gr-osmosdr deb package:
    # sudo apt-get install gr-osmosdr

Files

Path
/usr/bin/osmocom_fft
/usr/bin/osmocom_siggen
/usr/bin/osmocom_siggen_nogui
/usr/bin/osmocom_spectrum_sense
/usr/include/osmosdr/api.h
/usr/include/osmosdr/device.h
/usr/include/osmosdr/pimpl.h
/usr/include/osmosdr/ranges.h
/usr/include/osmosdr/sink.h
/usr/include/osmosdr/source.h
/usr/include/osmosdr/time_spec.h
/usr/include/osmosdr/swig/osmosdr_swig.i
/usr/include/osmosdr/swig/osmosdr_swig_doc.i
/usr/lib/python2.7/dist-packages/osmosdr/__init__.py
/usr/lib/python2.7/dist-packages/osmosdr/_osmosdr_swig.x86_64-linux-gnu.so
/usr/lib/python2.7/dist-packages/osmosdr/osmocom_siggen_base.py
/usr/lib/python2.7/dist-packages/osmosdr/osmosdr_swig.py
/usr/lib/x86_64-linux-gnu/libgnuradio-osmosdr.so
/usr/lib/x86_64-linux-gnu/pkgconfig/gnuradio-osmosdr.pc
/usr/share/doc/gr-osmosdr/changelog.Debian.amd64.gz
/usr/share/doc/gr-osmosdr/changelog.Debian.gz
/usr/share/doc/gr-osmosdr/copyright
/usr/share/gnuradio/grc/blocks/osmosdr_sink.xml
/usr/share/gnuradio/grc/blocks/osmosdr_source.xml
/usr/share/gnuradio/grc/blocks/rtlsdr_source.xml
/usr/share/man/man1/osmocom_fft.1.gz
/usr/share/man/man1/osmocom_siggen.1.gz
/usr/share/man/man1/osmocom_siggen_nogui.1.gz
/usr/share/man/man1/osmocom_spectrum_sense.1.gz

Changelog

2017-11-23 - A. Maitland Bottoms <bottoms@debian.org>
gr-osmosdr (0.1.4-14) unstable; urgency=medium
* Add initial support for Airspy HF+
* Support for FreeSRP via libfreesrp
2017-09-07 - A. Maitland Bottoms <bottoms@debian.org>
gr-osmosdr (0.1.4-13) unstable; urgency=medium
* update to v0.1.4-98-gc653754
* rtl-sdr bias-T support
* build with gnuradio-3.7.11
2016-10-14 - A. Maitland Bottoms <bottoms@debian.org>
gr-osmosdr (0.1.4-12) unstable; urgency=medium
* rebuild with airspy-host 1.0.9
2016-08-28 - A. Maitland Bottoms <bottoms@debian.org>
gr-osmosdr (0.1.4-11) unstable; urgency=medium
* Add SoapySDR support
2016-07-10 - A. Maitland Bottoms <bottoms@debian.org>
gr-osmosdr (0.1.4-10) unstable; urgency=medium
* build with gnuradio-3.7.10
2016-04-29 - A. Maitland Bottoms <bottoms@debian.org>
gr-osmosdr (0.1.4-9) unstable; urgency=medium
* update to v0.1.4-72-g164a09f
* rebuild on kfreebsd (Closes: #822132)
2016-01-13 - A. Maitland Bottoms <bottoms@debian.org>
gr-osmosdr (0.1.4-8) unstable; urgency=medium
* update to v0.1.4-67-gac15e78, build with gnuradio 3.7.9
2015-11-28 - A. Maitland Bottoms <bottoms@debian.org>
gr-osmosdr (0.1.4-7) unstable; urgency=medium
* Lintian cleanups pre-depends and dep5-copyright
2015-10-05 - A. Maitland Bottoms <bottoms@debian.org>
gr-osmosdr (0.1.4-6) unstable; urgency=medium
* Don't depend upon hackrf on non-linux
2015-09-30 - A. Maitland Bottoms <bottoms@debian.org>
gr-osmosdr (0.1.4-5) unstable; urgency=medium
* Rebuild with uhd 3.9.1-3

See Also

Package Description
gr-radar-doc_0.0.0.20180308-1_all.deb GNU Radio Radar Toolbox - Documentation
gr-radar_0.0.0.20180308-1+b3_amd64.deb GNU Radio Radar Toolbox
gr-rds_3.7.0.2.a542331-2+b3_amd64.deb GNU Radio FM RDS/TMC Transceiver
grabc_1.1-2+b2_amd64.deb simple program to determine the color string in hex by clicking on a pixel
grabix_0.1.7-1_amd64.deb wee tool for random access into BGZF files
grabserial_1.9.8-1_all.deb python-based serial dump and timing program
grace_5.1.25-6_amd64.deb XY graphing and plotting tool
gradle-apt-plugin_0.10-1_all.deb Gradle plugin to use Java annotation processors
gradle-completion_1.3.1-1_all.deb Bash and Zsh completion support for Gradle
gradle-debian-helper_2.0.2_all.deb Helper tools for building Debian packages with Gradle
gradle-doc_4.4.1-6_all.deb Powerful build system for the JVM - Documentations
gradle-ice-builder-plugin_1.4.5-1_all.deb Gradle plug-in for developing Ice applications in Java
gradle-plugin-protobuf_0.9.2-1_all.deb Protobuf Plugin for Gradle
gradle-propdeps-plugin_0.0.7-3_all.deb Gradle plugin enhancing the Maven integration
gradle_4.4.1-6_all.deb Powerful build system for the JVM
Advertisement
Advertisement