gem2deb_0.43_amd64.deb


Advertisement

Description

gem2deb - Debian Ruby packaging suite

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename gem2deb_0.43_amd64.deb
Package name gem2deb
Package version 0.43
Package release -
Package architecture amd64
Package type deb
Category admin::package-management implemented-in::ruby role::program ruby
Homepage -
License -
Maintainer Debian Ruby Extras Maintainers <pkg-ruby-extras-maintainers@lists.alioth.debian.org>
Download size 57.77 KB
Installed size 172.00 KB
gem2deb is a set of tools to create Debian package from ruby software
distributed with Rubygems. gem2tgz converts the .gem file to a tar archive,
then dh-make-ruby creates a Debian source package from that archive. That
Debian package uses the included Debhelper7 helper, dh_ruby, to generate
a proper Debian package. Both pure-ruby and native packages are supported.

Alternatives

Package Version Architecture Repository
gem2deb_0.43_i386.deb 0.43 i386 Debian Main
gem2deb - - -

Requires

Name Value
debhelper >= 11~
devscripts -
gem2deb-test-runner = 0.43
perl -
rake -
ruby -
ruby-all-dev >= 1:2.5
ruby-setup -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package gem2deb_0.43_amd64.deb
Source Package gem2deb

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install gem2deb deb package:
    # sudo apt-get install gem2deb

Files

Path
/usr/bin/dh-make-ruby
/usr/bin/dh_ruby
/usr/bin/dh_ruby_fixdepends
/usr/bin/dh_ruby_fixdocs
/usr/bin/gem2deb
/usr/bin/gem2tgz
/usr/bin/gen-ruby-trans-pkgs
/usr/lib/ruby/vendor_ruby/gem2deb.rb
/usr/lib/ruby/vendor_ruby/gem2deb/dh_make_ruby.rb
/usr/lib/ruby/vendor_ruby/gem2deb/dh_ruby.rb
/usr/lib/ruby/vendor_ruby/gem2deb/extension_builder.rb
/usr/lib/ruby/vendor_ruby/gem2deb/gem2tgz.rb
/usr/lib/ruby/vendor_ruby/gem2deb/gem_installer.rb
/usr/lib/ruby/vendor_ruby/gem2deb/installer.rb
/usr/lib/ruby/vendor_ruby/gem2deb/make.rb
/usr/lib/ruby/vendor_ruby/gem2deb/setup_rb_installer.rb
/usr/lib/ruby/vendor_ruby/gem2deb/version.rb
/usr/lib/ruby/vendor_ruby/gem2deb/dh_make_ruby/template/debian/compat
/usr/lib/ruby/vendor_ruby/gem2deb/dh_make_ruby/template/debian/control
/usr/lib/ruby/vendor_ruby/gem2deb/dh_make_ruby/template/debian/copyright
/usr/lib/ruby/vendor_ruby/gem2deb/dh_make_ruby/template/debian/rules
/usr/lib/ruby/vendor_ruby/gem2deb/dh_make_ruby/template/debian/watch
/usr/lib/ruby/vendor_ruby/gem2deb/dh_make_ruby/template/debian/source/format
/usr/share/doc/gem2deb/README
/usr/share/doc/gem2deb/TODO
/usr/share/doc/gem2deb/changelog.gz
/usr/share/doc/gem2deb/copyright
/usr/share/lintian/overrides/gem2deb
/usr/share/man/man1/dh-make-ruby.1.gz
/usr/share/man/man1/dh_ruby.1.gz
/usr/share/man/man1/dh_ruby_fixdepends.1.gz
/usr/share/man/man1/dh_ruby_fixdocs.1.gz
/usr/share/man/man1/gem2deb.1.gz
/usr/share/man/man1/gem2tgz.1.gz
/usr/share/man/man1/gen-ruby-trans-pkgs.1.gz
/usr/share/perl5/Debian/Debhelper/Buildsystem/ruby.pm
/usr/share/perl5/Debian/Debhelper/Buildsystem/rubysetuprb.pm
/usr/share/perl5/Debian/Debhelper/Sequence/ruby.pm

Changelog

2019-02-17 - Antonio Terceiro <terceiro@debian.org>
gem2deb (0.43) unstable; urgency=medium
* gem2deb-test-runner: deprecate --check-dependencies-only
* gem2deb-test-runner: add --check-bundler option
- This should not be used by packages targetting buster.
2019-02-08 - Antonio Terceiro <terceiro@debian.org>
gem2deb (0.42) unstable; urgency=medium
* GemInstaller: fix removal of temporary directory
* dh-make-ruby: restrict search for gemspecs to *.gemspec (Closes: #921703)
2019-02-03 - Antonio Terceiro <terceiro@debian.org>
gem2deb (0.41) unstable; urgency=medium
* dh-make-ruby: bump Standards-Version to 4.3.0 in template
* debian/control: bump Standards-Version to 4.3.0; no changes needed
otherwise
* Remove mentions to the require-rubygems check. It was already deprecated
and ignored in strecth.
2018-10-06 - Antonio Terceiro <terceiro@debian.org>
gem2deb (0.40) unstable; urgency=medium
* Remove Vincent Fourmond from Uploaders: by his request (Closes: #897289)
* dh-make-ruby:
- debian/control: add `Rules-Requires-Root: no`
- debian/control: bump Standards-Version to 4.2.1
* Bump Standards-Version to 4.2.1; no changes needed otherwise
2018-04-12 - Antonio Terceiro <terceiro@debian.org>
gem2deb (0.39) unstable; urgency=medium
* dh-make-ruby: use gemwatch.debian.net for debian/watch
2018-03-22 - Antonio Terceiro <terceiro@debian.org>
gem2deb (0.38.1) unstable; urgency=medium
* dh_ruby_fixdepends: don't touch dependencies of packages that do not
already depend on ruby (Closes: #892131)
2018-03-04 - Cédric Boutillier <boutil@debian.org>
gem2deb (0.38) unstable; urgency=medium
[ Antonio Terceiro ]
* dh_ruby_fixdepends: include upper bound on ruby versions provided by
ruby-all-dev (Closes: #889470)
* dh_ruby --print-supported: respect order provided by ruby-all-dev
[ Cédric Boutillier ]
* gem2tgz:
- Deprecate SHA1, and replace by SHA256
- Ensure that at least one of the checkable digests is listed in
checksums.yaml.gz instead of forcing all of them to be available
2018-02-25 - Antonio Terceiro <terceiro@debian.org>
gem2deb (0.37) unstable; urgency=medium
[ Georg Faerber ]
* debian/compat:
- Bump debhelper compat level to 11.
* debian/control:
- Add myself as uploader.
- Bump Standards-Version to 4.1.3, no changes needed.
- Bump required debhelper version to >= 11~.
- Use salsa.d.o in Vcs-{Browser,Git} fields.
- Drop obsolete Testsuite field.
* debian/copyright:
- Use HTTPS in link to copyright format spec.
- Point homepage link to salsa.d.o.
* dh-make-ruby:
- Bump Standards-Version to 4.1.3.
- Bump debhelper compat level to 11.
- Use salsa.d.o in Vcs-{Browser,Git} fields.
- Use HTTPS in link to copyright format spec.
[ Samuel Henrique ]
* dh-make-ruby:
- Use HTTPS in debian/watch template.
2017-09-15 - Antonio Terceiro <terceiro@debian.org>
gem2deb (0.36) unstable; urgency=medium
* dh-make-ruby:
- use `FIXME` in Section: when package name is not `ruby-*`, to avoid
tools being in section `ruby`.
- avoid calling wnpp-check twice
* gem2deb-test-runner: drop dependency on dpkg-dev. autopkgtest tests should
be for installed packages, and pulling development tools is Wrong™.
* Apply patch by James Clarke to fix crash when handling build failures in C
extensions (Closes: #851172)
2017-07-18 - Antonio Terceiro <terceiro@debian.org>
gem2deb (0.35) unstable; urgency=medium
* dh-make-ruby: bump debian/compat template to 10 (Closes: #867741)
* Gem2Deb::Metadata:
- use debian/gemspec as gemspec if it exists (Closes: #867739)
* gem2deb, dh-make-ruby: add -o/--offline option to prevent any access to
the internet (including but not limited to checking wnpp)

See Also

Package Description
gem_0.94-1_amd64.deb Graphics Environment for Multimedia - Pure Data library
gemdropx_0.9-8_amd64.deb Gem Drop X is an interesting one-player puzzle game for X11
gemma-doc_0.98.1+dfsg-1_all.deb Example folder for GEMMA
gemma_0.98.1+dfsg-1_amd64.deb Genome-wide Efficient Mixed Model Association
gems_1.1.1-2+b2_amd64.deb Shows a console session in several terminals
gendarme_4.2-3_all.deb extensible rule-based checker for CLI assemblies
genders_1.22-1+b1_amd64.deb cluster configuration management database tools
geneagrapher_1.0c2+git20180919-1_all.deb Create tree from Mathematics Genealogy Project
generator-scripting-language-examples_4.1.5-3_all.deb Examples for the Generator Scripting Language code generator
generator-scripting-language_4.1.5-3_amd64.deb Generator Scripting Language code generator
geneweb-gui_6.08+git20181019+dfsg-2_amd64.deb graphical user interface to Geneweb genealogy software
geneweb_6.08+git20181019+dfsg-2_amd64.deb genealogy software with web interface
genext2fs_1.4.1-4+b2_amd64.deb ext2 filesystem generator for embedded systems
gengetopt_2.22.6+dfsg0-3_amd64.deb skeleton main.c generator
genisoimage_1.1.11-3+b2_amd64.deb Creates ISO-9660 CD-ROM filesystem images
Advertisement
Advertisement