flashproxy-client_1.7-4_all.deb


Advertisement

Description

flashproxy-client - Pluggable transport to circumvent IP address blocking - client transport plugin

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename flashproxy-client_1.7-4_all.deb
Package name flashproxy-client
Package version 1.7
Package release 4
Package architecture all
Package type deb
Category net
Homepage https://crypto.stanford.edu/flashproxy/
License -
Maintainer Ximin Luo <infinity0@pwned.gg>
Download size 29.71 KB
Installed size 89.00 KB
Flashproxy is a tool to circumvent censorship by setting up many, generally
ephemeral, browser-based proxies, with the goal of outpacing a censor's
ability to enumerate and block the IP addresses of those proxies. Censored
clients can then connect to a Tor relay via these proxies, by using a
hard-to-block, low-bandwidth registration system called the facilitator.
This package contains the client transport plugin that enables censored Tor
users to circumvent censorship. It is compliant with the Tor pluggable
transports specification.

Alternatives

Package Version Architecture Repository
flashproxy-client_1.7-4_all.deb 1.7 all Debian Main
flashproxy-client - - -

Requires

Name Value
flashproxy-common = 1.7-4
python -
python:any >= 2.7~

Download

Type URL
Mirror ftp.br.debian.org
Binary Package flashproxy-client_1.7-4_all.deb
Source Package flashproxy

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install flashproxy-client deb package:
    # sudo apt-get install flashproxy-client

Files

Path
/usr/bin/flashproxy-client
/usr/bin/flashproxy-reg-appspot
/usr/bin/flashproxy-reg-email
/usr/bin/flashproxy-reg-http
/usr/bin/flashproxy-reg-url
/usr/share/doc/flashproxy-client/README
/usr/share/doc/flashproxy-client/changelog.Debian.gz
/usr/share/doc/flashproxy-client/changelog.gz
/usr/share/doc/flashproxy-client/copyright
/usr/share/doc/flashproxy-client/torrc
/usr/share/man/man1/flashproxy-client.1.gz
/usr/share/man/man1/flashproxy-reg-appspot.1.gz
/usr/share/man/man1/flashproxy-reg-email.1.gz
/usr/share/man/man1/flashproxy-reg-http.1.gz
/usr/share/man/man1/flashproxy-reg-url.1.gz

Changelog

2015-06-17 - Ximin Luo <infinity0@pwned.gg>
flashproxy (1.7-4) unstable; urgency=medium
* Actually make the documentation build reproducibly.
* Use the recently-decided standard variable SOURCE_DATE_EPOCH.
2015-03-30 - Ximin Luo <infinity0@pwned.gg>
flashproxy (1.7-3) unstable; urgency=medium
* Fix Vcs links.
* Make the documentation build reproducibly.
2014-11-05 - Ximin Luo <infinity0@pwned.gg>
flashproxy (1.7-2) unstable; urgency=medium
* Fix build for slower machines. (Closes: #765156)
* Update to latest Standards-Version. No changes required.
* Run overlooked proxy tests in debian/rules.
2014-08-06 - Ximin Luo <infinity0@pwned.gg>
flashproxy (1.7-1) unstable; urgency=low
* Initial release. (Closes: #721845)

See Also

Package Description
flashproxy-common_1.7-4_all.deb Pluggable transport to circumvent IP address blocking - common library
flashproxy-facilitator_1.7-4_all.deb Pluggable transport to circumvent IP address blocking - facilitator
flashproxy-proxy_1.7-4_all.deb Pluggable transport to circumvent IP address blocking - browser proxy
flashrom_1.0-1_amd64.deb Identify, read, write, erase, and verify BIOS/ROM/flash chips
flasm_1.62-10_amd64.deb assembler and disassembler for Flash (SWF) bytecode
flatlatex_0.8-1_all.deb Python3 LaTeX math converter to unicode text - binaries
flatpak-builder-tests_1.0.5-1_amd64.deb Application deployment framework for desktop apps (tests)
flatpak-builder_1.0.5-1_amd64.deb Flatpak application building helper
flatpak-tests_1.2.5-0+deb10u1_amd64.deb Application deployment framework for desktop apps (tests)
flatpak-xdg-utils-tests_1.0.0-1_amd64.deb as-installed tests for flatpak-xdg-utils
flatpak-xdg-utils_1.0.0-1_amd64.deb xdg-open and xdg-email reimplementation for containerized apps
flatpak_1.2.5-0+deb10u1_amd64.deb Application deployment framework for desktop apps
flatzinc_6.1.0-2_amd64.deb constraint problem modelling language
flawfinder_1.31-1_all.deb examines source code and looks for security weaknesses
fldiff_1.1+0-5_amd64.deb graphical diff program
Advertisement
Advertisement