debugedit_4.14.2.1+dfsg1-1_amd64.deb


Advertisement

Description

debugedit - tool to mangle source locations in .debug files

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename debugedit_4.14.2.1+dfsg1-1_amd64.deb
Package name debugedit
Package version 4.14.2.1+dfsg1
Package release 1
Package architecture amd64
Package type deb
Category admin
Homepage http://rpm.org/
License -
Maintainer RPM packaging team <team+pkg-rpm@tracker.debian.org>
Download size 1.27 MB
Installed size 1.30 MB
This tool allows rewriting of source code locations in .debug files
to point to /usr/src (or anywhere else). It has been split out of the
rpm package to be useful on its own.

Alternatives

Package Version Architecture Repository
debugedit_4.14.2.1+dfsg1-1_i386.deb 4.14.2.1+dfsg1 i386 Debian Main
debugedit - - -

Requires

Name Value
libc6 >= 2.14
libdw1 >= 0.167
libelf1 >= 0.144
libpopt0 >= 1.14
librpmio8 = 4.14.2.1+dfsg1-1

Replaces

Name Value
rpm << 4.11.1-2

Download

Type URL
Mirror ftp.br.debian.org
Binary Package debugedit_4.14.2.1+dfsg1-1_amd64.deb
Source Package rpm

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install debugedit deb package:
    # sudo apt-get install debugedit

Files

Path
/usr/bin/debugedit
/usr/lib/rpm/debugedit
/usr/share/doc/debugedit/NEWS.Debian.gz
/usr/share/doc/debugedit/changelog.Debian.gz
/usr/share/doc/debugedit/changelog.gz
/usr/share/doc/debugedit/copyright
/usr/share/man/man8/debugedit.8.gz

Changelog

2019-02-17 - Michal Čihař <nijel@debian.org>
rpm (4.14.2.1+dfsg1-1) unstable; urgency=medium
* New upstream release.
* Bump standards to 4.3.0.
2018-10-18 - Michal Čihař <nijel@debian.org>
rpm (4.14.2+dfsg1-1) unstable; urgency=medium
* New upstream release.
* Bump standards to 4.2.1.
2018-07-24 - Michal Čihař <nijel@debian.org>
rpm (4.14.1+dfsg1-4) unstable; urgency=medium
* Remove reference to upstream removed GROUPS document.
2018-05-31 - Michal Čihař <nijel@debian.org>
rpm (4.14.1+dfsg1-3) unstable; urgency=medium
* Use team address on tracker.debian.org as maintainer (Closes:
#899682).
* Move Vcs URLs to Salsa.
* Bump standards to 4.1.4.
* Remove constraint on historical Python version.
* Adjust debhelper dependency to have dh_update_autotools_conf
2018-03-14 - Michal Čihař <nijel@debian.org>
rpm (4.14.1+dfsg1-2) unstable; urgency=medium
* Build with libzstd-dev (Closes: #892759).
2018-01-23 - Michal Čihař <nijel@debian.org>
rpm (4.14.1+dfsg1-1) unstable; urgency=medium
* New upstream release.
* Remove old package replaces/conflicts from debian/control.
* Bump standards to 4.1.3.
2017-11-11 - Michal Čihař <nijel@debian.org>
rpm (4.14.0+dfsg1-2) unstable; urgency=medium
* Upload to unstable.
* Fixed compilation on architectures without MAP_POPULATE.
2017-11-08 - Michal Čihař <nijel@debian.org>
rpm (4.14.0+dfsg1-1) experimental; urgency=medium
* New upstream release.
- Fixes crashes on corrupted packages (Closes: #801456, #780309).
* Fix debian/watch to (again) changed upstream website.
* Use optional priority instead of extra.
* Avoid using deprecated autotools_dev debhelper.
* Bump standards to 4.1.1.
* Make rpm suggest python for one of helper scripts.
* Add binutils-dev to build depends.
2017-03-29 - Michal Čihař <nijel@debian.org>
rpm (4.12.0.2+dfsg1-2) unstable; urgency=medium
* Adjust debian/watch to new upstream website.
* Add patch to improve rpmsign behavior with gpgp2 (Closes: #858998).
2016-11-10 - Michal Čihař <nijel@debian.org>
rpm (4.12.0.2+dfsg1-1) unstable; urgency=medium
* New upstream release.
* Use HTTPS in the Vcs-* fields, and use the cgit frontend instead of
gitweb
* Build-depend on debhelper >= 9.20150628 to use --ddeb-migration

See Also

Package Description
decopy_0.2.4.1-2_all.deb Automatic debian/copyright Generator
dee-tools_1.2.7+17.10.20170616-4_amd64.deb Model to synchronize multiple instances over DBus - tooling
deepin-calculator_1.0.10-1_amd64.deb Calculator for DDE (Deepin Desktop Environment)
deepin-deb-installer_1.3.0-1_amd64.deb Deepin Package Manager
deepin-gettext-tools_1.0.8-4_all.deb Deepin Internationalization utilities
deepin-icon-theme_15.12.68-1_all.deb Icon Theme for Deepin software and Deepin Desktop Environment
deepin-image-viewer_1.3.8-1_amd64.deb Image Viewer for Deepin Desktop Environment
deepin-menu_3.4.1-1_amd64.deb Deepin menu service
deepin-movie_3.2.20-1_amd64.deb Deepin movie player
deepin-music_3.1.14+ds-1_amd64.deb music player with brilliant and tweakful UI
deepin-notifications_3.3.4-1_amd64.deb System notifications for Deepin Desktop Environment
deepin-picker_1.6.4-1_amd64.deb Color picker tool for deepin
deepin-screen-recorder_2.7.7-1_amd64.deb Simple recorder tools for deepin
deepin-screenshot_4.1.8-1_amd64.deb Advanced screen shoting tool
deepin-shortcut-viewer_1.3.5-2_amd64.deb Pop-up shortcut viewer for Deepin applications
Advertisement
Advertisement