debian-edu-install_2.10.21_all.deb


Advertisement

Description

debian-edu-install - Set d-i values to install Debian Edu without questions

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename debian-edu-install_2.10.21_all.deb
Package name debian-edu-install
Package version 2.10.21
Package release -
Package architecture all
Package type deb
Category misc uitoolkit::gtk
Homepage http://www.skolelinux.org
License -
Maintainer Debian Edu Developers <debian-edu@lists.debian.org>
Download size 60.44 KB
Installed size 99.00 KB
This package provides default answers for packages using debconf, and
configures services to work out of the box after an installation.
This is part of the Debian Edu project.

Alternatives

Package Version Architecture Repository
debian-edu-install_2.10.21_all.deb 2.10.21 all Debian Main
debian-edu-install - - -

Requires

Name Value
debconf >= 0.5
debconf-2.0 -
debian-edu-config -
eatmydata -
etckeeper -
libgtk3-perl -
lsb-base -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package debian-edu-install_2.10.21_all.deb
Source Package debian-edu-install

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install debian-edu-install deb package:
    # sudo apt-get install debian-edu-install

Files

Path
/etc/init.d/xdebian-edu-firstboot
/usr/lib/debian-edu-install/defaults.common
/usr/lib/debian-edu-install/defaults.ltsp-chroot
/usr/lib/debian-edu-install/defaults.ltsp-server
/usr/lib/debian-edu-install/defaults.main-server
/usr/lib/debian-edu-install/defaults.networked
/usr/lib/debian-edu-install/defaults.standalone
/usr/lib/debian-edu-install/defaults.workstation
/usr/lib/debian-edu-install/version
/usr/share/doc/debian-edu-install/changelog.gz
/usr/share/doc/debian-edu-install/copyright
/usr/share/lintian/overrides/debian-edu-install

Changelog

2019-03-24 - Holger Levsen <holger@debian.org>
debian-edu-install (2.10.21) unstable; urgency=medium
[ Wolfgang Schweer ]
* Set version number to 10+edu0 in preparation of the Debian Buster release.
2019-02-15 - Holger Levsen <holger@debian.org>
debian-edu-install (2.10.20) unstable; urgency=medium
* preseed-values/defaults.common:
- stop submitting to popcon.skolelinux.org as its unmaintained.
- use https for submitting to popcon.debian.org.
2019-01-27 - Holger Levsen <holger@debian.org>
debian-edu-install (2.10.19) unstable; urgency=medium
* d/rules:
- use dh_lintian instead of handcrafting commands.
- stop installing a lintian override for debian-edu-profile-udeb.
* Fix spelling error in previous changelog entry, thanks lintian.
2018-12-31 - Holger Levsen <holger@debian.org>
debian-edu-install (2.10.18) unstable; urgency=medium
[ Wolfgang Schweer ]
* Rework preseed files. It will allow one to reduce the number of #311188
issues:
- preseed-values/defaults.workstation:
Drop obsolete entries for cvs and xserver-xorg.
- preseed-values/defaults.standalone:
Drop obsolete entries for cvs, ntp-simple and ifupdown.
- preseed-values/defaults.networked:
+ Drop obsolete entry for ocsinventory-agent.
+ Use FQDN for the gosa-desktop URL.
+ Set nslcd/ldap-cacertfile string to point to the debian-edu-server.crt.
+ Change the nslcd/ldap-reqcert string from 'never' to 'demand'.
+ Add settings for lightdm and sddm (trying to prefer lightdm; sddm lacks
a language-chooser).
- preseed-values/defaults.common:
+ Drop obsolete entries for discover, ntp-simple, xserver-xorg, dash and
scsiadd.
+ Drop workaround for dictionaries-common/default-{ispell,wordlist}; the
related bug has probably been due to education-desktop-other
recommending tmispell-voikko. Preseeding both ispell and wordlist with
'Manual symlink setting' leaves the user without those if an application
doesn't choose one. That's maybe not what a user expects.
- preseed-values/defaults.main-server:
+ Drop obsolete entries for dhcp3-server, ntp-simple, calamaris,
foomatic-bin, fetchmail, squid, courier-base, courier-ssl and atftpd.
+ Adjust entries for bind9 (options) and tftpd-hpa (drop '--secure' option
so that both PXE and LTSP could be served).
- preseed-values/defaults.ltsp-server:
+ Drop obsolete entries for aftpd and dhcp3-server.
+ Adjust entries for slbackup (new default LTSP chroot) and tftpd-hpa.
[ Holger Levsen ]
* Bump standards version to 4.3.0, no changes needed.
2018-12-01 - Holger Levsen <holger@debian.org>
debian-edu-install (2.10.17) unstable; urgency=medium
* Rename debian-edu-install.lintian-override to
debian-edu-install.lintian-overrides to align it with the rest, also
adjust debian/rules as needed.
* Add debian/debian-edu-profile-udeb.lintian-overrides as lintian wrongly
tags uses-dpkg-database-directly. Also add a command to install this file
via debian/rules.

See Also

Package Description
debian-el_37.8_all.deb Transition package, debian-el to elpa-debian-el
debian-faq-de_9.0_all.deb Debian Frequently Asked Questions, in German
debian-faq-fr_9.0_all.deb Debian Frequently Asked Questions, in French
debian-faq-it_9.0_all.deb Debian Frequently Asked Questions, in Italian
debian-faq-nl_9.0_all.deb Debian Frequently Asked Questions, in Dutch
debian-faq-ru_9.0_all.deb Debian Frequently Asked Questions, in Russian
debian-faq-zh-cn_9.0_all.deb Debian Frequently Asked Questions, in Chinese
debian-faq_9.0_all.deb Debian Frequently Asked Questions
debian-goodies_0.84_all.deb Small toolbox-style utilities for Debian systems
debian-handbook_8.20180830_all.deb reference book for Debian users and system administrators
debian-history_2.23_all.deb Short History of the Debian Project
debian-installer-10-netboot-amd64_20190702_all.deb Debian-installer network boot images for amd64
debian-installer-10-netboot-arm64_20190702_all.deb Debian-installer network boot images for arm64
debian-installer-10-netboot-armel_20190702_all.deb Debian-installer network boot images for armel
debian-installer-10-netboot-armhf_20190702_all.deb Debian-installer network boot images for armhf
Advertisement
Advertisement