apertium-apy_0.11.4-2_all.deb


Advertisement

Description

apertium-apy - Apertium APY service

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package name apertium-apy
Package version 0.11.4
Package release 2
Package architecture all
Package type deb
Installed size 1.15 KB
Download size 345.25 KB
Official Mirror ftp.br.debian.org
This package contains Apertium APY which is simple Apertium
API written in Python 3 meant as a drop-in replacement for
ScaleMT.

Alternatives

Package Version Architecture Repository
apertium-apy_0.11.4-2_all.deb 0.11.4 all Debian Main
apertium-apy - - -

Requires

Name Value
adduser -
logrotate -
python3 >= 3.4
python3-pkg resources
python3-tornado >= 4.2
python3:any -

Download

Type URL
Binary Package apertium-apy_0.11.4-2_all.deb
Source Package apertium-apy

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install apertium-apy deb package:
    # sudo apt-get install apertium-apy

Files

Path
/etc/init.d/apertium-apy
/etc/logrotate.d/apertium-apy
/lib/systemd/system/apertium-apy.service
/usr/bin/apertium-apy
/usr/lib/python3/dist-packages/apertium_apy/__init__.py
/usr/lib/python3/dist-packages/apertium_apy/apy.py
/usr/lib/python3/dist-packages/apertium_apy/gateway.py
/usr/lib/python3/dist-packages/apertium_apy/keys.py
/usr/lib/python3/dist-packages/apertium_apy/missingdb.py
/usr/lib/python3/dist-packages/apertium_apy/mode_search.py
/usr/lib/python3/dist-packages/apertium_apy/systemd.py
/usr/lib/python3/dist-packages/apertium_apy-0.11.4.egg-info/PKG-INFO
/usr/lib/python3/dist-packages/apertium_apy-0.11.4.egg-info/dependency_links.txt
/usr/lib/python3/dist-packages/apertium_apy-0.11.4.egg-info/entry_points.txt
/usr/lib/python3/dist-packages/apertium_apy-0.11.4.egg-info/requires.txt
/usr/lib/python3/dist-packages/apertium_apy-0.11.4.egg-info/top_level.txt
/usr/lib/python3/dist-packages/apertium_apy/handlers/__init__.py
/usr/lib/python3/dist-packages/apertium_apy/handlers/analyze.py
/usr/lib/python3/dist-packages/apertium_apy/handlers/base.py
/usr/lib/python3/dist-packages/apertium_apy/handlers/coverage.py
/usr/lib/python3/dist-packages/apertium_apy/handlers/generate.py
/usr/lib/python3/dist-packages/apertium_apy/handlers/identify_lang.py
/usr/lib/python3/dist-packages/apertium_apy/handlers/list_language_names.py
/usr/lib/python3/dist-packages/apertium_apy/handlers/list_modes.py
/usr/lib/python3/dist-packages/apertium_apy/handlers/per_word.py
/usr/lib/python3/dist-packages/apertium_apy/handlers/pipe_debug.py
/usr/lib/python3/dist-packages/apertium_apy/handlers/speller.py
/usr/lib/python3/dist-packages/apertium_apy/handlers/stats.py
/usr/lib/python3/dist-packages/apertium_apy/handlers/suggestion.py
/usr/lib/python3/dist-packages/apertium_apy/handlers/translate.py
/usr/lib/python3/dist-packages/apertium_apy/handlers/translate_chain.py
/usr/lib/python3/dist-packages/apertium_apy/handlers/translate_doc.py
/usr/lib/python3/dist-packages/apertium_apy/handlers/translate_raw.py
/usr/lib/python3/dist-packages/apertium_apy/handlers/translate_webpage.py
/usr/lib/python3/dist-packages/apertium_apy/utils/__init__.py
/usr/lib/python3/dist-packages/apertium_apy/utils/translation.py
/usr/lib/python3/dist-packages/apertium_apy/utils/wiki.py
/usr/share/apertium-apy/langNames.db
/usr/share/apertium-apy/tools/apertium-recaptcha-test.html
/usr/share/apertium-apy/tools/apertium-viewer.html
/usr/share/apertium-apy/tools/serverlist-example
/usr/share/apertium-apy/tools/systemd/apy.service
/usr/share/apertium-apy/tools/sysvinit/apy.sh
/usr/share/apertium-apy/tools/upstart/apertium
/usr/share/apertium-apy/tools/upstart/apertium-all.conf
/usr/share/apertium-apy/tools/upstart/apertium-apy-gateway.conf
/usr/share/apertium-apy/tools/upstart/apertium-apy.conf
/usr/share/apertium-apy/tools/upstart/apertium-html-tools.conf
/usr/share/doc/apertium-apy/README.md.gz
/usr/share/doc/apertium-apy/README.systemd
/usr/share/doc/apertium-apy/changelog.Debian.gz
/usr/share/doc/apertium-apy/changelog.gz
/usr/share/doc/apertium-apy/copyright
/usr/share/man/man1/apertium-apy.1.gz

Changelog

2018-11-08 - Kartik Mistry <kartik@debian.org>
apertium-apy (0.11.4-2) unstable; urgency=low
* debian/apertium-apy.service:
+ Apertium-apy require UTF-8 locale to be available to work properly.
* debian/apertium-apy.1:
+ Added manpage.
2018-10-01 - Kartik Mistry <kartik@debian.org>
apertium-apy (0.11.4-1) unstable; urgency=low
* New upstream release.
* debian/control:
+ Bumped dh to 11.
+ Updated Standards-Version to 4.2.1
+ Updated Depends.
* debian/rules, debian/docs:
+ Install docs properly and remove extra license file.
2018-05-10 - Kartik Mistry <kartik@debian.org>
apertium-apy (0.11.3-1) unstable; urgency=low
[ Tino Didriksen ]
* Update to latest upstream release.
+ APy now installs /usr/bin/apertium-apy, so make use of that in services
* debian/control:
+ Fixed Vcs-* URLs.
+ Added missing Build-Depends on dh-python (Closes: #896719)
+ Reduced dh from 11 to 9.
+ Updated Standards-Version to 4.1.4
* Updated debian/Watch file for new upstream home
2018-02-10 - Kartik Mistry <kartik@debian.org>
apertium-apy (0.9.1~r343-4) unstable; urgency=low
* debian/control:
+ Updated URLs.
+ Updated Standards-Version to 4.1.3
* Bumped dh to 11.
* debian/rules:
+ Removed old comments.
* debian/copyright:
+ http->https.
* debian/apertium-apy.postinst:
+ Use non-recursive chown.
2017-08-12 - Kartik Mistry <kartik@debian.org>
apertium-apy (0.9.1~r343-3) unstable; urgency=low
* Remove upstart config file.
* debian/control:
+ Removed unneeded ${shlibs:Depends} from Depends.
+ Updated to Standards-Version 4.0.0
2016-12-10 - Kartik Mistry <kartik@debian.org>
apertium-apy (0.9.1~r343-2) unstable; urgency=low
* debian/control:
+ Depends on lsb-base (>= 3.0-6).
2016-06-11 - Kartik Mistry <kartik@debian.org>
apertium-apy (0.9.1~r343-1) unstable; urgency=low
[ Tino Didriksen ]
* New upstream release
* debian/control:
+ Fixed Depends field.
+ arch set to 'all'. We don't really compile.
+ Updated Standards-Version to 3.9.8
[ Kartik Mistry ]
* debian/control:
+ Fixed Vcs-Git URL.
+ Updated Build-Dep for arch:all.
2015-08-14 - Kartik Mistry <kartik@debian.org>
apertium-apy (0.1.0~r61425-1) unstable; urgency=low
* New upstream snapshot.
* debian/copyright:
+ Added license for toro.py
* debian/control:
+ Relaxed dependencies.
2015-07-17 - Kartik Mistry <kartik@debian.org>
apertium-apy (0.1.0~r61159-1) unstable; urgency=low
* Initial release (Closes: #769063)

See Also

Package Description
apertium-arg-cat_0.1.0~r64925-2_all.deb Apertium translation data for the Aragonese-Catalan pair
apertium-arg_0.1.2~r65494-2_all.deb Apertium single language data for Aragonese
apertium-bel-rus_0.2.0~r81186-2_all.deb Apertium translation data for the Belarusian-Russian pair
apertium-bel_0.1.0~r81357-2_all.deb Apertium single language data for Belarusian
apertium-br-fr_0.5.0~r61325-3_all.deb Apertium linguistic data to translate between Breton and French
apertium-ca-it_0.1.1~r57554-2_all.deb Apertium translation data for the Catalan-Italian pair
apertium-cat-srd_1.0.0~r82995-2_all.deb Apertium translation data for the Catalan-Sardinian pair
apertium-cat_2.6.0-1_all.deb Apertium single language data for Catalan
apertium-crh-tur_0.3.0~r83159-2_all.deb Apertium translation data for the Crimean Tatar-Turkish pair
apertium-crh_0.2.0~r83161-2_all.deb Apertium single language data for Crimean Tatar
apertium-cy-en_0.1.1~r57554-4_all.deb Apertium translation data for the Welsh-English pair
apertium-dan-nor_1.3.0~r67099-2_all.deb Apertium translation data for the Danish-Norwegian pair
apertium-dan_0.5.0~r67099-2_all.deb Apertium single language data for Danish
apertium-dev_3.5.2-1_amd64.deb Development tools and library for Apertium
apertium-en-ca_0.9.3~r61328-2_all.deb Apertium translation data for the English-Catalan pair
Advertisement
Advertisement