4store_1.1.6+20151109-2+b3_amd64.deb


Advertisement

Description

4store - RDF database storage and query engine -- database daemon

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename 4store_1.1.6+20151109-2+b3_amd64.deb
Package name 4store
Package version 1.1.6+20151109
Package release 2+b3
Package architecture amd64
Package type deb
Category devel::lang:sparql interface::daemon role::program uitoolkit::ncurses utils works-with::db works-with::semantic-data
Homepage https://github.com/garlik/4store
License -
Maintainer Jonas Smedegaard <dr@jones.dk>
Download size 392.05 KB
Installed size 2.44 MB
4store is a database storage and query engine that holds RDF data.
4store's main strengths are its performance, scalability and stability.
It does not provide many features over and above RDF storage and SPARQL
queries, but if your are looking for a scalable, secure, fast and
efficient RDF store, then 4store should be on your shortlist.
This package contains the database daemon and related utilities.

Alternatives

Package Version Architecture Repository
4store_1.1.6+20151109-2+b3_i386.deb 1.1.6+20151109 i386 Debian Main
4store - - -

Requires

Name Value
adduser -
libavahi-client3 >= 0.6.16
libavahi-common3 >= 0.6.16
libavahi-glib1 >= 0.6.16
libc6 >= 2.15
libglib2.0-0 >= 2.35.9
libncurses6 >= 6
libpcre3 -
libraptor2-0 >= 2.0.14
librasqal3 >= 0.9.31
libreadline7 >= 6.0
libstemmer0d >= 0+svn527
libtinfo6 >= 6
libuuid1 >= 2.16
libxml2 >= 2.6.27
netbase -
zlib1g >= 1:1.1.4

Download

Type URL
Mirror ftp.br.debian.org
Binary Package 4store_1.1.6+20151109-2+b3_amd64.deb
Source Package 4store

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install 4store deb package:
    # sudo apt-get install 4store

Files

Path
/etc/default/4store
/etc/init.d/4store
/usr/bin/4s-admin
/usr/bin/4s-backend
/usr/bin/4s-backend-copy
/usr/bin/4s-backend-destroy
/usr/bin/4s-backend-info
/usr/bin/4s-backend-passwd
/usr/bin/4s-backend-setup
/usr/bin/4s-boss
/usr/bin/4s-cluster-copy
/usr/bin/4s-cluster-create
/usr/bin/4s-cluster-destroy
/usr/bin/4s-cluster-file-backup
/usr/bin/4s-cluster-info
/usr/bin/4s-cluster-start
/usr/bin/4s-cluster-stop
/usr/bin/4s-delete-model
/usr/bin/4s-dump
/usr/bin/4s-file-backup
/usr/bin/4s-httpd
/usr/bin/4s-import
/usr/bin/4s-info
/usr/bin/4s-query
/usr/bin/4s-restore
/usr/bin/4s-size
/usr/bin/4s-ssh-all
/usr/bin/4s-ssh-all-parallel
/usr/bin/4s-update
/usr/share/doc/4store/INSTALL
/usr/share/doc/4store/README.Debian
/usr/share/doc/4store/TODO.Debian
/usr/share/doc/4store/buildinfo_amd64.gz
/usr/share/doc/4store/changelog.Debian.amd64.gz
/usr/share/doc/4store/changelog.Debian.gz
/usr/share/doc/4store/changelog.gz
/usr/share/doc/4store/copyright
/usr/share/doc/4store/glossary
/usr/share/doc/4store/protocol.gz
/usr/share/doc/4store/release
/usr/share/doc/4store/wire-format.gz
/usr/share/doc/4store/README.admin/README.md.gz
/usr/share/man/man1/4s-admin.1J.gz
/usr/share/man/man1/4s-backend-setup.1J.gz
/usr/share/man/man1/4s-cluster-create.1J.gz
/usr/share/man/man1/4s-cluster-destroy.1J.gz
/usr/share/man/man1/4s-cluster-info.1J.gz
/usr/share/man/man1/4s-cluster-start.1J.gz
/usr/share/man/man1/4s-cluster-stop.1J.gz
/usr/share/man/man1/4s-import.1J.gz
/usr/share/man/man1/4s-query.1J.gz
/usr/share/man/man5/4store.conf.5J.gz
/usr/share/man/man8/4s-boss.8J.gz

Changelog

2016-02-28 - Jonas Smedegaard <dr@jones.dk>
4store (1.1.6+20151109-2) unstable; urgency=medium
* Add patch 1011 to use _GNU_SOURCE instead of __USE_MISC.
Closes: Bug#810975. Thanks to Andreas Beckmann and Steven
Chamberlain.
* Update Vcs-git field: Use https protocol.
* Declare compliance with Debian Policy 3.9.7.
* Update copyright info:
+ Extend copyright of packaging to cover current year.
2015-12-26 - Jonas Smedegaard <dr@jones.dk>
4store (1.1.6+20151109-1) unstable; urgency=medium
[ upstream ]
* Snapshot of mainline git commit 3b1b659.
[ Jonas Smedegaard ]
* Update Vcs-Git field: Use canonical URL.
* Drop patch 1008: Applied upstream.
* Update copyright info:
+ Use License-Grant and License-Reference fields.
Thanks to Ben Finney.
* Add lintian override regarding license in License-Reference field.
See bug#786450.
* Bump debhelper compatibility level to 9.
* Add lintian override regarding debhelper 9.
* Fix have init script wait for avahi-daemon (not avahi).
Closes: Bug#731615. Thanks to Laurent Bigonville.
* Update package relations:
+ Stop depend (versioned) on lsb-base: Base package, and needed
version satisfied even in oldstable.
+ Relax to build-depend unversioned on d-shlibs: Needed version
satisfied even in oldstable.
2015-05-15 - Jonas Smedegaard <dr@jones.dk>
4store (1.1.6-2) unstable; urgency=medium
* Update Vcs-* fields.
* Update copyright info: Extend coverage for myself.
2015-02-09 - Jonas Smedegaard <dr@jones.dk>
4store (1.1.6-1) experimental; urgency=medium
[ upstream ]
* New upstream release.
[ Jonas Smedegaard ]
* Use github.com URLs as source and upstream Homepage.
* Drop dpkg-source local-options hint: Declared options are default
since dpkg-source 1.16.1.
* Install NEWS and docs files: No longer virtually empty.
* Install src/admin/README.md as documentation.
* Temporarily disable patches 1004-1005 (to handle PATH_MAX in a
portable way): Needs rewriting to use glib.
* Create more autotools files during build (no longer shipped
upstream).
* Unfuzz and update patches.
* Add patch 1010 to fix support FS_STORE_ROOT override in scripts.
* Enable regression tests, but only relaxed for experimental (largely
fails, possibly due to incomplete FS_STORE_ROOT override support).
* Update copyright info:
+ Skip copyright-check icon file.
+ Drop autotools-related Files and Copyright sections (no longer
shipped upstream).
+ Change license for (replaced) autogen.sh to BSD-3-clause.
+ Add swag-tests files licensed as W3C-Software-20021231.
* Work around upstream code assuming build directly from git.

See Also

Package Description
4ti2-doc_1.6.9+ds-1_all.deb mathematical tool suite for problems on linear spaces -- user guide
4ti2_1.6.9+ds-1_amd64.deb mathematical tool suite for problems on linear spaces -- tools
6tunnel_0.12-1_amd64.deb TCP proxy for non-IPv6 applications
7kaa-data_2.15.1+dfsg-1_all.deb Seven Kingdoms Ancient Adversaries - game data
7kaa_2.15.1+dfsg-1_amd64.deb Seven Kingdoms Ancient Adversaries: real-time strategy game
9base_6-7+b1_amd64.deb Plan 9 userland tools
9menu_1.9-2_amd64.deb Creates X menus from the shell
9mount_1.3+hg20170412-1_amd64.deb Plan 9 filesystem (v9fs) user mount utilities
9wm_1.4.1-1_amd64.deb X11 window manager inspired by Plan 9's rio
a2jmidid_8~dfsg0-3_amd64.deb Daemon for exposing legacy ALSA MIDI in JACK MIDI systems
a2ps_4.14-4_amd64.deb GNU a2ps - 'Anything to PostScript' converter and pretty-printer
a56_1.3+dfsg-9_amd64.deb Motorola DSP56001 assembler
a7xpg-data_0.11.dfsg1-10_all.deb chase action game - game data
a7xpg_0.11.dfsg1-10_amd64.deb chase action game
aa3d_1.0-8+b2_amd64.deb ASCII art stereogram generator
Advertisement
Advertisement