yamagi-quake2_7.40+ctf1.06~dfsg-1_i386.deb


Advertisement

Description

yamagi-quake2 - enhanced version of id Software's Quake II - client

Property Value
Distribution Debian 10 (Buster)
Repository Debian Contrib i386
Package filename yamagi-quake2_7.40+ctf1.06~dfsg-1_i386.deb
Package name yamagi-quake2
Package version 7.40+ctf1.06~dfsg
Package release 1
Package architecture i386
Package type deb
Category contrib/games game::fps implemented-in::c interface::graphical interface::x11 network::client role::program uitoolkit::sdl use::gameplaying x11::application
Homepage https://www.yamagi.org/quake2/
License -
Maintainer Debian Games Team <pkg-games-devel@lists.alioth.debian.org>
Download size 481.89 KB
Installed size 1.40 MB
This is the Yamagi Quake II Client, an enhanced Version of id Software's
Quake II. The main focus is single player, the gameplay and the graphics are
unchanged, but many bugs were fixed. This code is based upon Icculus Quake II,
which itself is built upon id Software's original code drop. Additional code
and patches by many contributors were used.
This engine is intended to be used via the wrapper script and menu entries
in the quake2 package.

Alternatives

Package Version Architecture Repository
yamagi-quake2_7.40+ctf1.06~dfsg-1_amd64.deb 7.40+ctf1.06~dfsg amd64 Debian Contrib
yamagi-quake2 - - -

Requires

Name Value
libc6 >= 2.28
libgl1 -
libsdl2-2.0-0 >= 2.0.9
yamagi-quake2-core = 7.40+ctf1.06~dfsg-1

Provides

Name Value
quake2-engine -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package yamagi-quake2_7.40+ctf1.06~dfsg-1_i386.deb
Source Package yquake2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install yamagi-quake2 deb package:
    # sudo apt-get install yamagi-quake2

Files

Path
/usr/lib/yamagi-quake2/quake2
/usr/lib/yamagi-quake2/ref_gl1.so
/usr/lib/yamagi-quake2/ref_gl3.so
/usr/lib/yamagi-quake2/baseq2/yq2.cfg
/usr/lib/yamagi-quake2/baseq2/models/crosshair/skin.pcx
/usr/lib/yamagi-quake2/baseq2/models/crosshair/tris.md2
/usr/share/doc/yamagi-quake2/01_index.md
/usr/share/doc/yamagi-quake2/02_installation.md.gz
/usr/share/doc/yamagi-quake2/03_configuration.md.gz
/usr/share/doc/yamagi-quake2/04_cvarlist.md.gz
/usr/share/doc/yamagi-quake2/05_packaging.md
/usr/share/doc/yamagi-quake2/06_contributing.md
/usr/share/doc/yamagi-quake2/07_multiplayer.md
/usr/share/doc/yamagi-quake2/NEWS.gz
/usr/share/doc/yamagi-quake2/README.md
/usr/share/doc/yamagi-quake2/changelog.Debian.gz
/usr/share/doc/yamagi-quake2/copyright
/usr/share/doc/yamagi-quake2/examples/cdripper.sh
/usr/share/doc/yamagi-quake2/examples/quake2-start.sh
/usr/share/lintian/overrides/yamagi-quake2

Changelog

2019-02-10 - Simon McVittie <smcv@debian.org>
yquake2 (7.40+ctf1.06~dfsg-1) unstable; urgency=medium
* New upstream release
- Refresh patch series
- Build-Depend on libcurl-dev
- Install new documentation
* Standards-Version: 4.3.0 (no changes required)
* Add Depends on libgl1, loaded via dlopen()
* Add Recommends on libopenal1, loaded via dlopen() as the preferred
audio backend (plain SDL is also possible)
* Add Suggests on various flavours of libcurl, optionally used for
download redirection
2018-12-08 - Bruno "Fuddl" Kleinert <fuddl@debian.org>
yquake2 (7.30+ctf1.05~dfsg-2) unstable; urgency=medium
* Team upload.
[ Simon McVittie ]
* Revert "Update maintainer address".
The lists.alioth.debian.org form is still canonical.
[ Bruno "Fuddl" Kleinert ]
* Fix broken symlink: /usr/share/doc/yamagi-quake2/NEWS ->
../yamagi-quake2-core/NEWS (Closes: #915867)
2018-09-08 - Simon McVittie <smcv@debian.org>
yquake2 (7.30+ctf1.05~dfsg-1) unstable; urgency=medium
* Update maintainer address
* New upstream release
- d/copyright: Update
* Install upstream CHANGELOG (which is actually just release notes) to
/usr/share/doc/package/NEWS.gz as recommended by Policy ยง12.7
* Standards-Version: 4.2.1 (no further changes required)
* Refresh patches
- d/p/Fix-segfault-in-OGG_PlayTrack-when-ogg_enable-is-set-to-z.patch,
d/p/Fix-spelling-of-information-and-re-word-a-comment-with-mu.patch:
Drop, applied upstream
2018-07-21 - Simon McVittie <smcv@debian.org>
yquake2 (7.21+ctf1.05~dfsg-1) unstable; urgency=medium
* d/README.source: Add a note about how to update to new upstream releases
* New upstream release
* Refresh patches
- d/p/Make-uses-of-pkg-config-cross-compilation-friendly.patch:
drop, applied upstream
* ctf-Use-SOURCE_DATE_EPOCH-for-reproducible-build.patch,
Link-ctf-game.so-to-math-library.patch,
Fix-some-spelling-mistakes-detected-by-Debian-s-Lintian-t.patch:
Mark some CTF patches as forwarded upstream
* d/p/Fix-segfault-in-OGG_PlayTrack-when-ogg_enable-is-set-to-z.patch:
Add post-release fix for a segfault with non-default configuration
* Standards-Version: 4.1.5 (no changes required)
* d/p/Fix-spelling-of-information-and-re-word-a-comment-with-mu.patch:
Fix more spellings flagged by Lintian
2018-06-12 - Simon McVittie <smcv@debian.org>
yquake2 (7.20+ctf1.05~dfsg-2) unstable; urgency=medium
* d/p/Make-uses-of-pkg-config-cross-compilation-friendly.patch:
Use $(PKG_CONFIG) so that cross-compilation can use an
appropriately-prefixed pkg-config
* d/rules: Explicitly set YQ2ARCH and YQ2OSTYPE instead of letting
the Makefile use uname -m and uname -s, for cross-compilation
* Note that cross-compilation requires a multiarch libopusfile-dev
(see #899138)
2018-03-11 - Simon McVittie <smcv@debian.org>
yquake2 (7.20+ctf1.05~dfsg-1) unstable; urgency=medium
* New upstream release
* d/copyright: Update
* Refresh patch series
* Fix-a-potential-crash-in-ai_run_melee-and-ai_run_missile.patch:
Apply a bugfix patch from upstream CTF module
2018-01-16 - Simon McVittie <smcv@debian.org>
yquake2 (7.10+ctf1.05~dfsg-2) unstable; urgency=medium
* Standards-Version: 4.1.3 (no changes required)
* Use https URL for Homepage
* Move packaging to salsa.debian.org
* d/gbp.conf: Make sure secondary ctf tarball is present
2017-12-10 - Simon McVittie <smcv@debian.org>
yquake2 (7.10+ctf1.05~dfsg-1) unstable; urgency=medium
* Standards-Version: 4.1.2 (no changes required)
* New upstream release
- Refresh patches
2017-11-06 - Simon McVittie <smcv@debian.org>
yquake2 (7.02+ctf1.05~dfsg-2) unstable; urgency=medium
* Standards-Version: 4.1.1 (no changes required)
* Set Rules-Requires-Root to no. With recent dpkg and debhelper
versions, this package can build without fakeroot.
* Move from deprecated priority extra to optional

See Also

Package Description
ydpdict_1.0.2+1.0.3-2+b2_i386.deb interface for Collins and Langenscheidt dictionaries
zfs-auto-snapshot_1.2.4-2_all.deb ZFS automatic snapshot service
zfs-dkms_0.7.12-2+deb10u1_all.deb OpenZFS filesystem kernel modules for Linux
zfs-dracut_0.7.12-2+deb10u1_all.deb OpenZFS root filesystem capabilities for Linux - dracut
zfs-initramfs_0.7.12-2+deb10u1_all.deb OpenZFS root filesystem capabilities for Linux - initramfs
zfs-test_0.7.12-2+deb10u1_i386.deb OpenZFS test infrastructure an support scripts
zfs-zed_0.7.12-2+deb10u1_i386.deb OpenZFS Event Daemon
zfsutils-linux_0.7.12-2+deb10u1_i386.deb command-line tools to manage OpenZFS filesystems
Advertisement
Advertisement