spectemu-x11_0.94a-20_i386.deb


Advertisement

Description

spectemu-x11 - Fast 48k ZX Spectrum Emulator for X11

Property Value
Distribution Debian 10 (Buster)
Repository Debian Contrib i386
Package filename spectemu-x11_0.94a-20_i386.deb
Package name spectemu-x11
Package version 0.94a
Package release 20
Package architecture i386
Package type deb
Category contrib/otherosfs field::computer-science hardware::emulation implemented-in::c interface::graphical interface::x11 role::program scope::utility uitoolkit::ncurses use::gameplaying use::simulating x11::application
Homepage -
License -
Maintainer Colin Watson <cjwatson@debian.org>
Download size 63.63 KB
Installed size 222.00 KB
xspect is the X11 version of Spectemu which emulates the 48k ZX
Spectrum, which uses the Z80 microprocessor.
It emulates the Z80 processor as well as the 48k Spectrum's other
hardware: keyboard, screen, sound, tape I/O. The emulation is very
close to the real thing, but it is still quite fast (It was reported
to be working well on a laptop with 486 at 25MHz!). On the other hand,
the user interface is not the best.
Features include:
- Sound support through Linux kernel sound-card driver.
- Snapshot saving and loading (.Z80 and .SNA format)
- Tape emulation: loading from tape files (.TAP and .TZX format)
- Optional quick loading of tapes.
- Saving to tape files.
- Separate utility to save tape files to real tape
- Configurable with config files and from command line

Alternatives

Package Version Architecture Repository
spectemu-x11_0.94a-20_amd64.deb 0.94a amd64 Debian Contrib
spectemu-x11 - - -

Requires

Name Value
libc6 >= 2.7
libreadline7 >= 6.0
libx11-6 -
libxext6 -
spectemu-common = 0.94a-20
spectrum-roms -

Provides

Name Value
xspectemu -

Conflicts

Name Value
xspectemu -

Replaces

Name Value
xspectemu -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package spectemu-x11_0.94a-20_i386.deb
Source Package spectemu

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install spectemu-x11 deb package:
    # sudo apt-get install spectemu-x11

Files

Path
/usr/bin/xspect
/usr/share/doc/spectemu-x11
/usr/share/man/man1/xspect.1.gz
/usr/share/menu/spectemu-x11

Changelog

2018-10-27 - Colin Watson <cjwatson@debian.org>
spectemu (0.94a-20) unstable; urgency=medium
[ Colin Watson ]
* Move VCS to salsa.debian.org.
[ Ondřej Nový ]
* d/control: Remove trailing whitespaces
2016-12-31 - Colin Watson <cjwatson@debian.org>
spectemu (0.94a-19) unstable; urgency=medium
* Update Vcs-Browser URL for alioth cgit.
* Use HTTPS for Vcs-* URLs.
* Use dh-exec to simplify override_dh_install target.
2014-01-02 - Colin Watson <cjwatson@debian.org>
spectemu (0.94a-18) unstable; urgency=medium
* Switch to git; adjust Vcs-* fields.
* Add a couple more <stdlib.h> inclusions for exit().
2013-06-07 - Colin Watson <cjwatson@debian.org>
spectemu (0.94a-17) unstable; urgency=low
[ Colin Watson ]
* Build-depend on debhelper (>= 9~) directly rather than requiring a
Lintian override for use of 8.9.0.
[ Moritz Muehlenhoff ]
* Remove the spectemu-svga package, since svgalib is scheduled for removal
(closes: #711115).
2013-02-09 - Colin Watson <cjwatson@debian.org>
spectemu (0.94a-16) unstable; urgency=low
* Use dh-autoreconf.
* Remove config-guess-sub.patch in favour of updating config.guess and
config.sub automatically at build time.  dh_autoreconf does not take
care of that by default because spectemu does not use automake.
2012-06-22 - Colin Watson <cjwatson@debian.org>
spectemu (0.94a-15) unstable; urgency=low
* Fix passing of build flags to utils/Makefile.
2011-10-21 - Colin Watson <cjwatson@debian.org>
spectemu (0.94a-14) unstable; urgency=low
* Drop -ltermcap rather than unnecessarily build-depending on
libncurses5-dev.  Thanks, Sven Joachim.
2011-10-20 - Colin Watson <cjwatson@debian.org>
spectemu (0.94a-13) unstable; urgency=low
* Explicitly build-depend on libncurses5-dev, since libreadline6-dev no
longer depends on it.
* Use dpkg-buildflags and debhelper 9 to set default compiler flags.
2011-07-24 - Colin Watson <cjwatson@debian.org>
spectemu (0.94a-12) unstable; urgency=low
* Use architecture restriction in spectemu-common's Suggests field rather
than a substvar; this is sanctioned by policy 3.9.1.
* Update Vcs-Bzr field for Alioth changes.
2010-05-09 - Colin Watson <cjwatson@debian.org>
spectemu (0.94a-11) unstable; urgency=low
* Convert to source format 3.0 (quilt) and DEP-3 patch tagging.

See Also

Package Description
speech-dispatcher-baratinoo_0.9.0-6_i386.deb Speech Dispatcher: Baratinoo (VoxyGen) output module
speech-dispatcher-ibmtts_0.9.0-6_i386.deb Speech Dispatcher: IBM TTS output module
speech-dispatcher-kali_0.9.0-6_i386.deb Speech Dispatcher: Kali output module
speech-dispatcher-pico_0.9.0-6_i386.deb Speech Dispatcher: Pico output module
sqlcl-package_0.1.1_all.deb Oracle SQL Developer Command-Line Debian package builder
sqldeveloper-package_0.5.4_all.deb Oracle SQL Developer Debian package builder
sugar-etoys-activity_116-7_all.deb Etoys activity for Sugar Learning Platform
susv2_7.20180621_all.deb Fetch and install SUSv2
susv3_7.20180621_all.deb Fetch and install SUSv3
susv4_7.20180621_all.deb Fetch and install SUSv4 (POSIX.1-2017)
synphot-data_0.9.12+dfsg-2_all.deb Optional data files for pysynphot
thunar-dropbox-plugin_0.2.1+dfsg1-5_i386.deb context-menu items from dropbox for Thunar
translate-shell_0.9.6.9-1_all.deb Command-line translator using Google Translate, etc
ttf-mscorefonts-installer_3.7_all.deb Installer for Microsoft TrueType core fonts
tuxonice-userui_1.1+dfsg1.gc3bdd83-4+b1_i386.deb user-space interfaces for TuxOnIce
Advertisement
Advertisement